A Subset of users may experience intermittent problems authenticating to the IAM Cloud Platform
Incident Report for IAM Cloud
Postmortem

Root Cause Analysis (RCA) Issued 23rd January 2018

SUMMARY:

At 09:44 on 23rd January our Infrastructure team were alerted of errors that a newly applied certificate was not trusted by browsers causing errors when authenticating to federated applications. Engineers immediately put a workaround in place which caused a degradation in performance for a subset of users while the full issue was resolved.

ROOT CAUSE:

IAM Cloud engineers had recently performed a certificate replacement and upgrade across all environments. A discrepancy was identified between the certificate issued by our certificate supplier, Go Daddy, and that which was stored on the revocation server hosted by Go Daddy.

RESOLUTION and MITIGATION

Re-keying and redistributing the certificate resolved the discrepancy between certificate issued and that hosted by Go Daddy. An additional step has been added to our certificate replacement process in order to ensure such issues are not possible in the future.

We thank you for your patience.

Kind Regards Victoria Hamblin CCO @IAM Cloud

Posted over 1 year ago. Jan 23, 2018 - 13:39 UTC

Resolved
This incident has been resolved.
Posted over 1 year ago. Jan 23, 2018 - 13:33 UTC
Monitoring
The issue has been isolated to a subset of EU servers where an upgrade was made to our certificates. We have implemented a workaround while the team work with our certificate supplier on full resolution for all users. Thank you for your patience while we resolve the issue fully and a Full RCA will be issued within 24 hours to all impacted users.

Kind Regards
Victoria Hamblin
CCO @IAM Cloud
Posted over 1 year ago. Jan 23, 2018 - 10:50 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted over 1 year ago. Jan 23, 2018 - 10:33 UTC
Investigating
A Subset of customers may experience problems authenticating via the IAM Cloud Platform. Engineers are working to resolve this issue as a priority and we will provide further updates ASAP.

We apologise for the inconvenience.

IAM Cloud Technical Support

http://support.iamcloud.com

support@iamcloud.com

Phone (UK): +44 118 324 0000

Phone (US): +1 914 495 1298
Posted over 1 year ago. Jan 23, 2018 - 10:21 UTC