Intermittent access to Cloud Drive Mapper
Incident Report for IAM Cloud
Postmortem

Root Cause Analysis (RCA) Issued on 4th August

SUMMARY: On Monday 31st July at 22:56 UTC IAM Cloud Engineers were alerted to a large number of users being unable to access Cloud Drive Mapper.

ROOT CAUSE: An undocumented change made by Microsoft prevented Cloud Drive Mapper from obtaining the federation details required to access CDM. The specific change caused a rejection to our ACCEPT parameter within the body of the home realm discovery call. This resulted in a 400 error code being returned.

SOLUTION: On Tuesday the 1st August at 07:30 UCT the fix was isolated and an emergency fix was authorised and released within 24 hours.

MITIGATION: The technical team are working with Microsoft to ensure we are proactively advised of all changes made so we can ensure no impact to our service.

Victoria Slee

Chief Customer Officer

Posted Aug 04, 2017 - 16:40 UTC

Resolved
Update
IAM Cloud engineers are currently working on an update to Cloud Drive Mapper to resolve the on going connection issue. Affected customers will be notified as soon as it becomes available.
Posted Aug 03, 2017 - 07:58 UTC
Update
The fix for Cloud Drive Mapper is still undergoing final testing, it will be made available as soon as its ready for release
Posted Aug 02, 2017 - 20:36 UTC
Update
The fix for Cloud Drive Mapper is undergoing final testing, it will be made available as soon as its ready for release.
Posted Aug 02, 2017 - 14:17 UTC
Update
Cloud Drive Mapper fix has been identified and engineers are currently finalising an update to resolve the issue. New version will be available ASAP and our support team will assist with rolling out to any affected customers.
Posted Aug 02, 2017 - 08:35 UTC
Identified
Cloud Drive Mapper fix has been identified and engineers are currently finalising an update to resolve the issue. New version will be available by 9:00 AM UK time and our support team will assist with rolling out to any affected customers.
Posted Aug 01, 2017 - 22:58 UTC
Update
IAM Cloud engineers are still working to resolve this problem, further updates will be posted as they become available
Posted Aug 01, 2017 - 16:58 UTC
Update
IAM Cloud engineers are still working to resolve this problem, further updates will be posted as they become available.
Posted Aug 01, 2017 - 11:35 UTC
Investigating
We've been alerted to an error message on Cloud Drive Mapper stating - 'You are blocked from running IAM Cloud's Cloud Drive Mapper. Please contact your helpdesk'.

This is preventing users from accessing CDM. Our developers are investigating. Further updates to follow.
Posted Aug 01, 2017 - 07:58 UTC