A subset of users may experience degraded performance on Cloud Drive Mapper
Incident Report for IAM Cloud
Resolved
This incident has been resolved.
Posted Oct 19, 2020 - 19:20 UTC
Update
Further updates on our efforts to mitigate this problem can be found here - https://support.iamcloud.com/support/solutions/articles/12000074536-files-folders-missing-from-drive-view
Posted Sep 25, 2020 - 07:24 UTC
Identified
SharePoint Online (SPO) service availability

We are aware of some transient issues with drives mapped to Office 365 that can temporarily result in the contents of the drive appearing invisible. This can be resolved by the user right-clicking in the File Explorer window and hitting 'Refresh' or hitting F5 on their keyboard.

This underlying reason for this behavior is caused by the drive's webdav requests receiving a 503 'service unavailable' response from SharePoint Online, which is something that Office 365 responds with when it is under serious load.

This is not necessarily just the load within your tenancy. Unfortunately this can also happen when other Office 365 customers who are consuming services in the same SPO server farm as your organisation collectively start exceeding overall safe load thresholds.

Microsoft don't officially comment on performance patterns, but it seems quite likely based on our own experience of running 24/7 Azure services that the current issues may be linked to the return of universities which cause a huge surge of Office 365 usage. Hopefully if this is the case, we should expect things to return to normal next week.

What can you do?

In the very short-term, users can resolve this themselves by refreshing the file explorer. But we know this is far from ideal for anything more than a very brief stop-gap. Another thing you can do is to update to the latest version of Cloud Drive Mapper (2.7.x) because we have significantly reduced the amount of traffic it sends to Office 365. This is not only likely to help mitigate the problem a bit in your own tenancy, but it is also a nice neighborly thing to do because it will help reduce load across the whole SPO farm.

In the meantime, while we can't control whether SharePoint Online occasionally provides 503 requests, we are looking into options to be able to better handle the way the drives respond to 503s to make it less disruptive to the users. We'll keep this status page updated with progress on this issue.

We apologize for the inconvenience. If you require any further information then please contact our support team.

IAM Cloud Technical Support

http://support.iamcloud.com

support@iamcloud.com

Phone (UK): +44 118 324 0000

Phone (US): +1 914 495 1298
Posted Sep 22, 2020 - 18:40 UTC
This incident affected: Cloud Drive Mapper (Office 365 Availability).