Microsoft Outage Notification
Incident Report for IAM Cloud
Resolved
This incident has been resolved.
Posted 6 months ago. Jan 08, 2019 - 15:31 UTC
Monitoring
Microsoft is currently experiencing several global issues with Exchange Online affecting the Outlook desktop client. For updates on this issue, please visit Microsoft's Office 365 Admin Centre.
Posted 6 months ago. Jan 08, 2019 - 12:15 UTC
This incident affected: Authentication Service (Office 365).