Customers using v2.8 of Cloud Drive Mapper will need to update to v2.11
Incident Report for IAM Cloud
Resolved
This incident has been resolved.
Posted Nov 28, 2022 - 14:57 UTC
Update
We are continuing to monitor for any further issues.
Posted Aug 23, 2022 - 17:02 UTC
Update
We are continuing to monitor for any further issues.
Posted Aug 23, 2022 - 16:59 UTC
Monitoring
IF YOU ARE USING CLOUD DRIVE MAPPER VERSION 2.9 OR ABOVE, YOU CAN DISREGARD THIS MESSAGE

Overview:

Over the past week we have been alerted to some of our customers becoming unable to authenticate to Microsoft 365 with older versions of Cloud Drive Mapper, specifically v2.8.10.1 or below.

Microsoft hasn’t actively reported any changes, but from our diagnostics we understand it to be related to a low-level interaction change between older versions of MSAL and Azure AD.

MSAL is Microsoft’s modern authentication library that Cloud Drive Mapper uses to integrate into Microsoft 365.
Microsoft periodically updates MSAL, and when it does we include the updated version in our next scheduled release of CDM. The last major MSAL update was included in version 2.9.

If you already using version 2.9 or above then you do not need to take any actions. However if you are using 2.8.10.1 or below we recommend you to update to the latest version of Cloud Drive Mapper (currently 2.11.x.x).

However, before you update there are some important configuration changes that you should be aware of. These are described below, but if in any doubt our support team is available to help at support@iamcloud.com / https://support.iamcloud.com

More about the issue:

Affected customers are reporting the following error message:

AADSTS9000411: The request is not properly formatted. The parameter 'login_hint' is duplicated.

As with most Microsoft changes, they are rolled out tenancy-by-tenancy rather than globally in one big bang. So, it is possible that customers who so far haven’t experienced any issues, may do so soon. For this reason, to prevent future interruption, we are now recommending for all customers and partners to update to the latest version of Cloud Drive Mapper (version 2.11.x.x), which can be obtained from https://resources.iamcloud.net

The MSI can be installed over the top of the previous one in line with your current deployment method. Please note that as we have moved over to WebView2 to remove any dependency on the IE11 engine. The installer now has both the x86 and x64 components for this included which has increased the installer size, however the CDM application itself is still roughly the same size as previous versions. Full details can be found in our change log: https://www.iamcloud.com/iam-changelog/

There may be some prerequisite steps/config changes required to ensure a smooth transition. These may include:

• Upgrading to the .NET version to 4.8, this is required for versions 2.9 and above of CDM
• Re-adding the latest CDM Azure AD enterprise application, due to changes in permissions between versions. This can be re adding in to Azure AD by following this article - https://support.iamcloud.com/en/support/solutions/articles/12000055246-cloud-drive-mapper-and-azure-ad-permissions-important-
• Adding our new ‘MasterSettings’ or ‘ListConvergeSettings’ registry key, to customise the behaviour of your converged drive. Details on this can be found on - https://support.iamcloud.com/en/support/solutions/articles/12000079992-cloud-drive-mapper-registry-settings
• If folder redirection is in use, then the current keys will need to be replaced with the new ‘FolderRedirectionSettings’ registry key. Details on this can be found on - https://support.iamcloud.com/en/support/solutions/articles/12000085178-simple-folder-redirection-using-folderredirectionsettings

If you’re unsure of what registry keys need changing, then forward a screenshot of:

Computer\HKEY_CURRENT_USER\Software\IAM Cloud\CloudDriveMapper
&
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\IAM Cloud\CloudDriveMapper

to support@iamcloud.com and our support team will advise on what to do.

For any further any further information or queries regarding the upgrade then please get in touch with our support team who will be happy to provide any assistance required.

https://support.iamcloud.com
support@iamcloud.com
Phone (UK): +44 118 324 0000
Posted Aug 23, 2022 - 11:27 UTC
This incident affected: Cloud Drive Mapper (Cloud Drive Mapper).