Incident Summary: A subset of v2 customers receive an M365 authentication error when using CDM.
Services affected: CDM v2 (Legacy)
Current impact: • Impacted v2 customers receive a Microsoft authentication error notification and cannot access the CDM service • Issue is limited to a subset of v2 customers, and will remain v2 exclusive • Issue is multi-region
Latest resolution status: A fix has been released and is being provided to impacted customers individually. Any customers who are experiencing the issue for the first time should raise a case with our Support team as per standard process.
Root cause has been associated with WebDAV vulnerability fixes released by MS as part of their Patch Tuesday maintenance update.
Fix ETA: Released.
Next update: n/a
Posted Jun 12, 2025 - 20:19 UTC
Update
Incident Summary: A subset of v2 customers receive an M365 authentication error when using CDM.
Services affected: CDM v2 (Legacy)
Current impact: • Impacted v2 customers receive a Microsoft authentication error notification and cannot access the CDM service • Issue is limited to a subset of v2 customers, and will remain v2 exclusive • Issue is multi-region
Latest resolution status: Root cause has been associated at present to a series of fixes to WebDAV vulnerabilities released by MS as part of their Patch Tuesday maintenance update.
A fix has been identified and is being progressed through testing. Impacted customers will be informed of the updated client version once testing has completed and the release confirmed as viable.
Fix ETA: 21:00
Next update: 21:00
Posted Jun 12, 2025 - 16:24 UTC
Update
Incident Summary: A subset of v2 customers receive an M365 authentication error when using CDM.
Services affected: CDM v2 (Legacy)
Current impact: • Impacted v2 customers receive a Microsoft authentication error notification and cannot access the CDM service • Issue is limited to a subset of v2 customers, and will remain v2 exclusive • Issue is multi-region
Latest resolution status: There have been no changes to the CDM v2 client which is servicing customer application requests as expected. We understand the issue is with the post-authentication exchange between CDM and SharePoint due to a change in SharePoint behaviour effected by Microsoft.
We are investigating if a repairing change to the CDM v2 client can be developed to accommodate the revised SharePoint behaviour should this remain permanent.
CDM v3 architecture means that this version is unaffected by the MS breaking change, and we are confident that it will remain so.
Customers who are currently impacted may be required to expedite migration to CDM v3 if a repairing change to CDM v2 cannot be developed. We will continue to update as our remediation activities progress.
Fix ETA: None at present
Next update: 16:00
Posted Jun 12, 2025 - 12:17 UTC
Update
Incident Summary: A subset of v2 customers receive an M365 authentication error when using CDM v2
Services affected: CDM v2 (Legacy)
Current impact: - Impacted v2 customers receive a Microsoft authentication notification and cannot access the CDM service - Issue is limited to a subset of v2 customers - Issue is multi-region
Latest resolution status: There have been no changes to the CDM v2 client which is servicing customer application requests as expected.
The issue arises within M365 post-authentication. We are investigating as to the cause of the issue and if it relates to a change to an M365 component which interacts with the v2 client.
We continue to recommend customers raise the issue with Microsoft whilst we continue internal root cause investigations.
Fix ETA: None at present, dependent on root cause
Next update: 14:00
Posted Jun 12, 2025 - 10:54 UTC
Update
We are continuing to monitor for any further issues.
Posted Jun 12, 2025 - 07:49 UTC
Update
This is now affecting UK and EU based clients. Investigations are continuing, the advice is to still raise a support ticket with Microsoft.
Posted Jun 12, 2025 - 07:48 UTC
Monitoring
All of our systems are operating normally and there have been no changes to the CDM v2 client software.
Our current understanding is that the issue occurs at the Microsoft Entra sign in step, therefore we advise customers experiencing this issue to raise a support ticket with Microsoft.
Will will continue to monitor the issue given the onward service impact.
Posted Jun 11, 2025 - 18:18 UTC
Investigating
We've received reports from a small number of US based clients that V2 Cloud Drive Mapper is not authenticating to Office 365.
The error message states 'Something went wrong. We're sorry, sign-in isn't working right now. But we're on it!' Followed by a correlation ID and other generic information.
Its unclear what the cause of the error is. We're carrying out investigations. Further updates to follow.