Notification of scheduled Maintenance to the IAM Cloud Portal
Incident Report for IAM Cloud
Resolved
This incident has been resolved.
Posted Mar 20, 2020 - 21:24 UTC
Identified
During this time portal.iamcloud.net will be unavailable due to essential maintenance work. Downtime is expected to be one hour.

Any queries can be directed to our support desk at support@iamcloud.com
Posted Mar 20, 2020 - 16:33 UTC
This incident affected: IAM Cloud Portal.