Information on changes to Microsoft 365 API permissions when using mapped drives to SharePoint Online
Incident Report for IAM Cloud
Resolved
We've just launched our latest release of Cloud Drive Mapper: Version 2.8. This latest release includes a significant number of fixes and improvements, plus several minor changes in drive behaviour and registry settings. Please read this changelog post before updating:

https://www.iamcloud.com/changelog/cloud-drive-mapper-2-8/
Posted Jun 03, 2021 - 14:46 UTC
Monitoring
Due to recent changes in Microsoft 365 API permissions, Cloud Drive Mapper now requires customers to implement our "Advanced" Azure AD Enterprise App in order to map drives to SharePoint Online. Previously this requirement had only been needed for our 'Converged Drives'.

If you have already added the EnableAdvanceMode = true registry setting then no action is needed.

But if you do not have this regkey, then we highly recommend adding it ASAP and following the instructions in this article to add and approve the Cloud Drive Mapper Advanced AAD Enterprise App: https://support.iamcloud.com/en/support/solutions/articles/12000055246-cloud-drive-mapper-and-azure-ad-permissions-important-

If you have any questions or need any assistance, please don't hesitate to contact us at support@iamcloud.com

Kind regards,

IAM Cloud Support
Posted May 12, 2021 - 12:01 UTC
This incident affected: Cloud Drive Mapper (Cloud Drive Mapper).