The IAM Cloud Administration Portal will be offline today for maintenance
Incident Report for IAM Cloud
Resolved
This incident has been resolved.
Posted about 1 year ago. Jul 09, 2018 - 12:52 UTC
Update
We are continuing to investigate this issue.
Posted about 1 year ago. Jul 09, 2018 - 10:18 UTC
Investigating
The IAM Cloud Administration Portal will remain offline today for critical maintenance. Normal service will resume tomorrow.

We apologise for the inconvenience.
Posted about 1 year ago. Jul 09, 2018 - 10:13 UTC
This incident affected: IAM Cloud Portal and Identity Service (Office 365 Licensing).