We are experiencing delays to AD password resets syncing to IAM Cloud in both EU and US
Incident Report for IAM Cloud
Resolved
Engineers have identified the root cause as an issue with our current Azure System which hosts our password service. We received alerts that the machine which holds this part of the service needed re-imaging. This is part of our old infrastructure which is scheduled to be upgraded on the weekend of the 6th July thus future incidents of this nature will be fully mitigated.

Thank you for your patience.

Victoria Hamblin
IAM Cloud's CCO
Posted 10 months ago. Jun 29, 2018 - 12:09 UTC
Identified
We are currently experiencing delays to AD password resets syncing to IAM Cloud in both EU and US. Engineers are investigating the issue as a priority and we will continue to keep you posted on progress.

We apologise for the inconvenience.
Posted 10 months ago. Jun 29, 2018 - 11:46 UTC
This incident affected: Password Service (Active Directory Resets).