A Subset of EU customers may experience delays in password resets
Incident Report for IAM Cloud
Resolved
This incident has been resolved.
Posted 10 months ago. Sep 10, 2018 - 08:25 UTC
Investigating
A Subset of EU customers may experience problems resetting passwords. Engineers are working to resolve this issue as a priority and we will provide further updates ASAP.

We apologise for the inconvenience.

IAM Cloud Technical Support

http://support.iamcloud.com

support@iamcloud.com

Phone (UK): +44 118 324 0000

Phone (US): +1 914 495 1298

Phone (India) +91 7276413892

Phone (South Africa): +27 31 100 1924

Phone (Hong Kong): +852 5801 4528
Posted 10 months ago. Sep 10, 2018 - 08:13 UTC
This incident affected: Password Service (Self Service Resets, Active Directory Resets) and Authentication Service (Single Sign On, Login Control).