Autosave and Office app files not working correctly from mapped drives
Incident Report for IAM Cloud
Resolved
We’ve not had official confirmation from Microsoft yet, but from what we’ve tested, version 2307 (Build 16626.20134) of Office has stopped exhibiting the error behaviour. However, to ensure correct compatibility with CDM, version 2.20 will need to be used.

This can be found at resources.iamcloud.net. This has been fully tested internally but as usual we'd recommend to test on a small user base first, before mass deployment.

The change log can be found here – https://www.iamcloud.com/iam-changelog/cloud-drive-mapper-2-20/

If you require any further information, then please contact our support team at support@iamcloud.com
Posted Jul 31, 2023 - 15:56 UTC
Update
We are continuing to monitor for any further issues.
Posted Jul 11, 2023 - 17:02 UTC
Update
We are aware that many customers are still experiencing issues with office files after upgrading their Microsoft Office to version 2306 from the current channel. We have seen problems across co-authoring, links in files and macros to name but a few.

We are actively working this problem as our highest priority. We have a support case open with Microsoft and we encourage our customers to also open a case via Microsoft 365 support in relation to this breaking change in Office, in order to further increase the visibility of this in the Microsoft Organisation.

We recommend using SharePoint or Teams converge where the workflows are suitable for your business. However we strongly recommend reverting back to Office version 2305 on the current channel and holding off until the current problem with 2306 is either addressed by Microsoft, or until we have found a graceful solution to the problem.
Posted Jul 11, 2023 - 17:00 UTC
Update
We are continuing to monitor for any further issues.
Posted Jul 04, 2023 - 10:44 UTC
Monitoring
A few weeks ago, we identified an issue in the preview build of Office (version 2306) in the current deployment channel. The problems related to co-authoring Office documents and network drives. Autosave wasn't working and various error messages were being returned when trying to open Office files in certain workflows. So far this has only affected mappings to OneDrive and static SharePoint locations. It does not affect converge drives.

We escalated the issue with Microsoft and are still in communication with the Office product team. This doesn’t just affect Cloud Drive Mapper but Microsoft’s own native WebDAV service as well. However despite ongoing talks, 2306 has now gone into production with these issues remaining. Despite us believing that this is a genuine bug, rather than an intentional change, we decided to hedge the risk by building a workaround to the problem. Cloud Drive Mapper v2.19 has a new solution for Office co-authoring and overcomes the issues introduced in Office 2306 for Word, Excel and PowerPoint. We recommend upgrading to this latest version to mitigate against these issues.

It can be downloaded from resources.iamcloud.net. The change log can be found here - https://www.iamcloud.com/changelog/

If any further information then please contact our support team at support@iamcloud.com
Posted Jul 04, 2023 - 10:24 UTC
This incident affected: Cloud Drive Mapper (Cloud Drive Mapper).