Customers using version 2.7 and below of Cloud Drive Mapper will need to update to version 2.8
Incident Report for IAM Cloud
Resolved
This incident has been resolved.
Posted Nov 03, 2021 - 17:21 UTC
Monitoring
In the past few weeks, Microsoft has been making some changes to Azure AD that has led to a number of our customers becoming unable to authenticate to Microsoft 365 with older versions of Cloud Drive Mapper. Microsoft hasn’t actively reported any changes, but from our diagnostics we understand it to be related to a low-level interaction change between MSAL and AAD. As with most Microsoft changes, they are rolled out tenancy-by-tenancy rather than globally in one big bang. So it is possible that customers who so far haven’t experienced any issues, may do in the coming weeks. For this reason, to prevent future interruption, we are now recommending for all customers and partners to update to the latest version of Cloud Drive Mapper (version 2.8.6.1) which can be obtained from resources.iamcloud.net.

However – before you do, please note that depending on which version of Cloud Drive Mapper you are updating from, there may be some prerequisite steps/config changes required to ensure a smooth transition. These may include:

From 2.8.1.x and above:

• If you are using a version between 2.8.1 and 2.8.4 then just the client will need updating.

From 2.7 and below:

• Re-adding the latest CDM Azure AD enterprise application, due to changes in permissions between versions. This can be re adding in to Azure AD by following this article - https://support.iamcloud.com/en/support/solutions/articles/12000055246-cloud-drive-mapper-and-azure-ad-permissions-important-

Important: Please note that this change will be tenancy-wide, and will impact users still on previous versions of the client – therefore it is recommended that you deploy the latest version of CDM to all users, not just a subset, and at the same time as the enterprise app is updated in Azure AD. It is also recommended that you make this change out of business hours to minimize impact during the transition.

• Adding our new ‘MasterSettings’ registry key, to customise the behaviour of your converged drive.
We have documented these changes in our release notes at www.iamcloud.com/changelog , but if you are unsure about anything please feel free to contact our support team at support@iamcloud.com before upgrading. And most importantly, please make sure to do a good amount of testing with the latest version before deploying to production.
Posted Aug 24, 2021 - 11:00 UTC
This incident affected: Cloud Drive Mapper (Cloud Drive Mapper).