We are continuing to monitor for any further issues.
Posted Aug 18, 2025 - 08:26 UTC
Update
We are continuing to monitor for any further issues.
Posted Aug 15, 2025 - 18:48 UTC
Monitoring
Microsoft is currently making a change to its RPS service within SharePoint Online that can stop CDM V2's authentication and ability to map drives.
There are three things you can do to resolve the issue:
1) Upgrade CDM V2 to our latest build CDM 2.24 (download available at https://resources.iamcloud.net). CDM 2.24 doesn't require RPS to authenticate, and is a permanent fix to this issue.
2) If your tenancy has already been hit by the change in the RPS service and you are under pressure to get colleagues back up and running ASAP, there is a simple fix you can do to temporarily resolve the issue: re-enable RPS.
Once you've run this, all versions of CDM V2 should start working again. But this is temporary, and will only work until 15th October 2025 when Microsoft intends to remove RPS entirely. As such, we still recommend upgrading to 2.24 as soon as possible too.
3) Upgrade to CDM V3 - which is unaffected by these changes. However we don't recommend you rush this, as V3 is different technology to V2 and requires more substantial testing in your environment before deployment.
As such our recommendation would be for all V2 customers to upgrade to 2.24 ASAP, which should be a relatively simple update, then start their journey with testing V3, ready for a potential roll-out within the next few months.
Posted Aug 15, 2025 - 10:55 UTC
Identified
We are aware of a change Microsoft is making to its RPS service within SharePoint Online that can break CDM V2's authentication and ability to map drives.
We have more information on this coming soon.
Posted Aug 14, 2025 - 21:51 UTC
This incident affects: Cloud Drive Mapper (Cloud Drive Mapper legacy).