Incident Summary: Global service impact due to MS Azure failure
Regions impacted: Global
Services affected: CDM v2 Legacy & v3 Iris
Current impact: Services are available as normal
Latest resolution status: MS state that all primary resources are now recovered; Azure customers using Azure Front Door (AFD) should see consistent availability, with slightly higher latencies decreasing as additional resources are recovered
Fix ETA: Resolved
Next update: n/a
Posted Oct 09, 2025 - 14:17 UTC
Update
Incident Summary: Global service impact due to MS Azure failure
Regions impacted: Global
Services affected: CDM v2 Legacy & v3 Iris
Current impact: CDM and Iris performance is largely restored to normal following MS rollout of remediation to affected Azure Front Door resources
Latest resolution status: MS estimate that 96% of impacted resources have now been recovered.
Fix ETA: Dependent on Microsoft
Next update: 15:00
Posted Oct 09, 2025 - 12:13 UTC
Monitoring
Incident Summary: Global service impact due to MS Azure failure
Regions impacted: Global
Services affected: CDM v2 Legacy & v3 Iris
Current impact: CDM users will be experiencing a intermittent service with possible degraded performance Iris users cannot use the service to administer users or tenancies
Latest resolution status: We are currently monitoring the issue but are reliant on Microsoft to restore service.
Incident Summary: Global service impact due to MS Azure failure
Regions impacted: Global
Services affected: CDM v2 Legacy & v3 Iris
Current impact: CDM users will be experiencing a intermittent service with possible degraded performance Iris users cannot use the service to administer users or tenancies
Latest resolution status: We are observing a significant Microsoft issue which is impacting IAM Cloud. We are currently monitoring the issue but are reliant on Microsoft to restore service.
Fix ETA: Dependent on Microsoft
Next update: 12:00
Posted Oct 09, 2025 - 09:30 UTC
This incident affected: Cloud Drive Mapper (Cloud Drive Mapper legacy, Cloud Drive Mapper) and Iris (admin portal).