Legacy (CDM v2) Portal unreachable via Chrome / Firefox

Incident Report for IAM Cloud

Resolved

The issue is now resolved and users can access the legacy Portal as normal via Chrome and Firefox.

Thank you for your patience whilst Google corrected the unsafe site classification.
Posted Apr 18, 2025 - 06:33 UTC

Monitoring

We have revalidated the domain with Google. Googles process documentation states that it can be a couple of days before verification is processed.

We will continue to monitor the situation and we ask that affected Admins use Microsoft Edge while this issue persists.
Posted Apr 17, 2025 - 16:38 UTC

Update

No status change.

Next update:
When the issue is resolved.
Posted Apr 17, 2025 - 15:31 UTC

Update

We have revalidated the domain with Google.

Next update:
16:15
Posted Apr 17, 2025 - 14:16 UTC

Update

We are continuing to work on a fix for this issue.
Posted Apr 17, 2025 - 14:11 UTC

Update

We are still waiting for the propagation to replicate.

Latest resolution status:
Edge can be used.

Next update:
When the issue is resolved.
Posted Apr 17, 2025 - 13:25 UTC

Identified

We have revalidated the domain and are awaiting propagation.
Posted Apr 17, 2025 - 11:03 UTC

Investigating

This is reoccurrence of the previous issue on the 7th April.

Incident Summary: 
The legacy CDM Portal (portal.iamcloud.net) has been classified as unsafe when using Chrome & Firefox browsers

Services affected:
Legacy CDM (v2)

Current impact:
CDM v2 administrators will be unable to reach the Portal if using Chrome or Firefox.
Our suggested workaround is to use a different browser (e.g. Edge).

Latest resolution status:
A workaround is currently available.

We have provided feedback to the browser vendors to inform them that the site has been incorrectly classified as unsafe.

Next update:
12:30
Posted Apr 17, 2025 - 10:33 UTC
This incident affected: IAM Cloud Legacy Portal.