A subset of clients may experience degraded performance on Cloud Drive Mapper
Incident Report for IAM Cloud
Resolved
IAM Cloud would like to apologise for the disruption that our clients have experienced recently with Cloud Drive Mapper. We started receiving reports of the problem at 08:00 UK time on the 2nd Nov and immediately began investigations into identifying the cause of the issue.

The morning of 3rd Nov we managed to successfully determine the cause of the problem in our test environment and implement a fix for it. We have now completed testing on version 2.8.10.1 of CDM, which is available at resources.iamcloud.net, this contains the fix for the authentication issue that we identified. Further details can be found in our change log - https://www.iamcloud.com/iam-changelog/cloud-drive-mapper-2-8-10-1/

The updated version will need to be deployed out as per your deployment method. The msi will install over the top of the old one ok.

Also in the Azure Active Directory admin portal under enterprise apps, you will have either Cloud Drive Mapper Advanced, Cloud Drive Mapper Standard, or both of them.

In the permissions section you'll see a button named 'Grant admin consent for (tenancy name)' - this will need to be pressed too for the new app to work, but it can be done either before or after deployment.

Please note - if you are upgrading from 2.7 or below, then there are some further considerations to consider, detailed here - https://www.iamcloudstatus.com/incidents/szmx92f542f0

If any further information is required then please contact our support desk.

IAM Cloud Technical Support

http://support.iamcloud.com

support@iamcloud.com

Phone (UK): +44 118 324 0000
Posted Nov 03, 2021 - 17:51 UTC
Identified
Update - 08:55 GMT 03/11

The issue has been identified and fixed in our test environment. We're building this into an updated version of CDM. This will be released at resources.iamcloud.net once its available. Further update to follow in due course.

If any further information is required then please contact our support desk.

IAM Cloud Technical Support

http://support.iamcloud.com

support@iamcloud.com

Phone (UK): +44 118 324 0000
Posted Nov 03, 2021 - 08:55 UTC
Investigating
We are currently investigating an issue whereby users are receiving an 'Unable to authenticate' error message on Cloud Drive Mapper. This usually coincides with a small authentication window over the Cloud Drive Mapper icon on the taskbar.

Our team are working to determine the cause of the error so that a fix can then be implemented.

We apologise for the inconvenience caused. If you require any further information then please contact our support desk.

IAM Cloud Technical Support

http://support.iamcloud.com

support@iamcloud.com

Phone (UK): +44 118 324 0000
Posted Nov 02, 2021 - 18:05 UTC
This incident affected: Cloud Drive Mapper (Cloud Drive Mapper).